Ubuntu deb パッケージ

Ubuntu 用のレポジトリを公開しています。


  1. このレポジトリについて
  2. インストール
  3. karmic から lucid へのアップグレード
  4. Ubuntu 9.10(karmic)用パッケージリスト
  5. Ubuntu 10.04(lucid)用パッケージリスト
  6. 旧レポジトリ

このレポジトリについて

電脳 Ruby プロジェクトの製品群 の Ubuntu パッケージを公開しています.

インストール

まず、下記の注)を読んでください。

[システム] → [システム管理] → [アップデート・マネージャ] → [設定]

そこで、[他のソフトウェア]タブをクリック。 [追加]をクリックし、APTラインに

• karmic 用

 deb http://ppa.launchpad.net/abe-gfd-dennou/ppa/ubuntu karmic main 
 deb-src http://ppa.launchpad.net/abe-gfd-dennou/ppa/ubuntu karmic main  

または

• lucid 用

 deb http://ppa.launchpad.net/abe-gfd-dennou/ppa/ubuntu lucid main 
 deb-src http://ppa.launchpad.net/abe-gfd-dennou/ppa/ubuntu lucid main  

を追加して

 $ sudo apt-get update  

をし、目的に応じて apt-get でインストールをしてください。

★ gave をインストールすると dennou-ruby 製品が全部入ります。

 

karmic から lucid へのアップグレード

karmic 版の gave を既にインストールしている人は、lucid 版のレポジトリを追加した後に

 $ sudo apt-get upgrade 

をすればよいです。

(この時、karmic 版のレポジトリは無効にしておいてください。)

 

注) 下記の「旧レポジトリ」からインストールしたパッケージは

 $ sudo apt-get remove <パッケージ名>
 $ sudo apt-get autoremove 

をしてください。

そして/etc/apt/sources.list にて、そのレポジトリをコメントアウト、または削除してから上記の「インストール」を行ってください。

その後にパッケージをインストールして

 $ sudo apt-get upgrade 

を行い、もしエラーが出た場合は

 $ sudo apt-get -f install 
 $ sudo apt-get upgrade

とすればとりあえずはうまくいきます。

 

☆ lucid 版の libdap について

universe レポジトリ(lucid)に、libdap のパッケージが既にありました。

本家のパッケージを使用する方が無難だと思いますので、そうしてください。

<方法>

 まず、 2010/05/11 以前に、このレポジトリにあった libdap を gave とともにインストールした人は、削除してください。

  $ sudo apt-get remove gave
  $ sudo apt-get autoremove 

 次に、universe レポジトリが有効になっていることを確認してください。

 [システム] → [システム管理] → [アップデート・マネージャ] → [設定] → [Ubuntu のソフトウェア]タブをクリック。

 [コミュニティによってメンテナンスされるオープンソースソフトウェア(universe)]にチェックが入っていることを確認。

 そして

  $ sudo apt-get update
  $ sudo apt-get install gave 

 とすればよいです。

 

Ubuntu 9.10(karmic)用パッケージリスト

karmic 用のパッケージ一覧は以下の通りです。

== list of packages for karmic(i386, amd64, lpia) ==

 · gave

 · gphys

 · libdap

 · libnc-dap

 · narray-miss

 · netcdf-ruby

 · numru-met

 · numru-misc

 · numru-units

 · ruby-dcl

 · ruby-fftw3

 · dcl-c

 · dcl-gfortran

 · dcl-f90-gfortran

 · dennou-sty-6

 · easyvtk

 · htroff

 · mksigen

 · multibitnums

 · rttool

 · ruby-gpv

 

Ubuntu 10.04(lucid)用パッケージリスト

lucid 用のパッケージ一覧は以下の通りです。

== list of packages for lucid(i386, amd64) ==

 · gave

 · gphys

 · libdap

 · libnc-dap

 · narray-miss

 · netcdf-ruby

 · numru-met

 · numru-misc

 · numru-units

 · ruby-dcl

 · ruby-fftw3

 · dcl-c

 

旧レポジトリ

# karmic(9.10) 用
deb ftp://www.gfd-dennou.org/library/cc-env/Linux/ubuntu-dennou karmic/
deb-src ftp://www.gfd-dennou.org/library/cc-env/Linux/ubuntu-dennou karmic/

# jaunty(9.04) 用
deb ftp://www.gfd-dennou.org/library/cc-env/Linux/ubuntu-dennou jaunty/
deb-src ftp://www.gfd-dennou.org/library/cc-env/Linux/ubuntu-dennou jaunty/

# intrepid(8.10) 用
deb ftp://www.gfd-dennou.org/library/cc-env/Linux/ubuntu-dennou intrepid/
deb-src ftp://www.gfd-dennou.org/library/cc-env/Linux/ubuntu-dennou intrepid/

# hardy(8.04) 用
deb ftp://www.gfd-dennou.org/library/cc-env/Linux/ubuntu-dennou hardy/
deb-src ftp://www.gfd-dennou.org/library/cc-env/Linux/ubuntu-dennou hardy/

/etc/apt/sources.list に記述し、目的に応じて apt-get でインストールして下さい。 ただし、旧レポジトリのアップロードは今後しないつもりです。

今現在(2010/05)、旧レポジトリの運用は停止しています。ご了承ください。

 

作成:abe, otobe


Last Updated: 2010/05/12 (Miki Abe), Since: 2010/04/12 (Miki Abe)